0025114: CMake-based build tools for OCCT 7.0
[occt.git] / src / TKMesh / CMakeLists.txt
diff --git a/src/TKMesh/CMakeLists.txt b/src/TKMesh/CMakeLists.txt
new file mode 100644 (file)
index 0000000..bb9d8a8
--- /dev/null
@@ -0,0 +1,14 @@
+project(TKMesh)
+
+set (TOOLKIT_MODULES
+  BRepMesh
+)
+
+if(NOT WIN32)
+  if(USE_TBB)
+    list( APPEND USED_LIBS tbb )
+    list( APPEND USED_LIBS tbbmalloc )
+  endif()
+endif()
+
+include(${OCCT_SOURCE_DIR}/adm/cmake/BuildToolkit.cmake)