0028060: Samples - Objects in Geometry/Viewer2d have incorrect color
[occt.git] / samples / mfc / standard / 01_Geometry / CMakeLists.txt
index 051970a..9c0eb68 100644 (file)
@@ -32,13 +32,11 @@ set (Geometry_ISESSION2D_HEADER_FILES ${Geometry_ISESSION2D_DIR}/ISession_Curve.
                                       ${Geometry_ISESSION2D_DIR}/ISession_Direction.h
                                       ${Geometry_ISESSION2D_DIR}/ISession_Point.h
                                       ${Geometry_ISESSION2D_DIR}/ISession_Surface.h
-                                      ${Geometry_ISESSION2D_DIR}/ISession_Text.h
                                       ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.h)
 set (Geometry_ISESSION2D_SOURCE_FILES ${Geometry_ISESSION2D_DIR}/ISession_Curve.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Direction.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Point.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Surface.cpp
-                                      ${Geometry_ISESSION2D_DIR}/ISession_Text.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.cpp)
 
 set (Geometry_RESOURCE_DIR            ${MFC_STANDARD_SAMPLES_DIR}/01_Geometry/res)
@@ -69,11 +67,18 @@ add_executable (Geometry WIN32 ${Geometry_SOURCE_FILES}
 
 set_property(TARGET Geometry PROPERTY FOLDER Samples)
 
-install (TARGETS Geometry RUNTIME DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/bin${BUILD_POSTFIX}"
-                          ARCHIVE DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/lib${BUILD_POSTFIX}"
-                          LIBRARY DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/lib${BUILD_POSTFIX}")
+if (SINGLE_GENERATOR)
+  install (TARGETS Geometry DESTINATION "${INSTALL_DIR_BIN}")
+else()
+  install (TARGETS Geometry
+           CONFIGURATIONS Release RelWithDebInfo
+           DESTINATION "${INSTALL_DIR_BIN}")
+  install (TARGETS Geometry
+           CONFIGURATIONS Debug
+           DESTINATION "${INSTALL_DIR_BIN}d")
+endif()
 
-include_directories (${OCCT_ROOT}/inc
+include_directories (${CMAKE_BINARY_DIR}/inc
                      ${Geometry_SRC_DIR}
                      ${Geometry_ISESSION2D_DIR}
                      ${Geometry_RESOURCE_DIR}