0033661: Data Exchange, Step Import - Tessellated GDTs are not imported
[occt.git] / samples / mfc / standard / 01_Geometry / CMakeLists.txt
index fbe3267..0e4a255 100644 (file)
@@ -1,4 +1,10 @@
-cmake_minimum_required (VERSION 2.6)
+# Caution! Be careful, when increase minimal cmake version:
+# using of newer version may leads (by default) to applying
+# of some new policies. It may break compilation.
+# For canceling of applying new policies use:
+# cmake_policy(PUSH) before `cmake_minimum_required`
+# and cmake_policy(POP) after.
+cmake_minimum_required (VERSION 3.1 FATAL_ERROR)
 
 project (Geometry)
 
@@ -32,16 +38,12 @@ set (Geometry_ISESSION2D_HEADER_FILES ${Geometry_ISESSION2D_DIR}/ISession_Curve.
                                       ${Geometry_ISESSION2D_DIR}/ISession_Direction.h
                                       ${Geometry_ISESSION2D_DIR}/ISession_Point.h
                                       ${Geometry_ISESSION2D_DIR}/ISession_Surface.h
-                                      ${Geometry_ISESSION2D_DIR}/ISession_Text.h
-                                      ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.h
-                                      ${Geometry_ISESSION2D_DIR}/ISession2D_SensitiveCurve.h)
+                                      ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.h)
 set (Geometry_ISESSION2D_SOURCE_FILES ${Geometry_ISESSION2D_DIR}/ISession_Curve.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Direction.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Point.cpp
                                       ${Geometry_ISESSION2D_DIR}/ISession_Surface.cpp
-                                      ${Geometry_ISESSION2D_DIR}/ISession_Text.cpp
-                                      ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.cpp
-                                      ${Geometry_ISESSION2D_DIR}/ISession2D_SensitiveCurve.cpp)
+                                      ${Geometry_ISESSION2D_DIR}/ISession2D_Curve.cpp)
 
 set (Geometry_RESOURCE_DIR            ${MFC_STANDARD_SAMPLES_DIR}/01_Geometry/res)
 set (Geometry_RESOURCE_HEADER         ${Geometry_RESOURCE_DIR}/resource.h)
@@ -69,13 +71,20 @@ add_executable (Geometry WIN32 ${Geometry_SOURCE_FILES}
                                ${Geometry_RESOURCE_FILES}
                                ${Geometry_RESOURCE_HEADER})
 
-set_property(TARGET Geometry PROPERTY FOLDER Samples)
+set_property(TARGET Geometry PROPERTY FOLDER "Samples/mfc")
 
-install (TARGETS Geometry RUNTIME DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/bin${BUILD_POSTFIX}"
-                          ARCHIVE DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/lib${BUILD_POSTFIX}"
-                          LIBRARY DESTINATION "${INSTALL_DIR}/win${COMPILER_BITNESS}/${COMPILER}/lib${BUILD_POSTFIX}")
+if (SINGLE_GENERATOR)
+  install (TARGETS Geometry DESTINATION "${INSTALL_DIR_BIN}")
+else()
+  install (TARGETS Geometry
+           CONFIGURATIONS Release RelWithDebInfo
+           DESTINATION "${INSTALL_DIR_BIN}")
+  install (TARGETS Geometry
+           CONFIGURATIONS Debug
+           DESTINATION "${INSTALL_DIR_BIN}d")
+endif()
 
-include_directories (${OCCT_ROOT}/inc
+include_directories (${CMAKE_BINARY_DIR}/inc
                      ${Geometry_SRC_DIR}
                      ${Geometry_ISESSION2D_DIR}
                      ${Geometry_RESOURCE_DIR}